Digest for jooq-user@googlegroups.com - 4 updates in 1 topic

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Digest for jooq-user@googlegroups.com - 4 updates in 1 topic

http://groups.google.com/group/jooq-user/topics mailing list
Mark Derricutt <[hidden email]>: Aug 28 09:02PM +1200

Lukas - does this mean that JOOQ doesn’t promise to get binary (or source) compatible even between patch releases?
 
I don’t use the code-gen myself favouring manually constructing the table/fields declarations where we use it (and we lock down our versions and prevent mismatched versions) but not everyone is doing crazy things like that.
 
But yeh, if doing code-gen - probably best to use the generator for the version you’re shipping with.
 
Mark
 
 
Lukas Eder <[hidden email]>: Aug 28 11:59AM +0200

Hi Mark,
 
If code is re-generated using version X, it is always a good idea to also
upgrade the library version to X. However, just upgrading the library to
version X should not cause any trouble if the generated code is still on an
older version Y.
 
In general, we are binary compatible between patch releases. I cannot think
of a binary incompatible change between 3.11.7 and 3.11.12, although I
might overlook something, of course.
 
I hope this helps,
Lukas
 
Nicola Micheli <[hidden email]>: Aug 28 03:07AM -0700

I found solution I use springBootVersion = "2.1.1.RELEASE" and this have
dependency jooq 3.11.7 then I change with springBootVersion =
"2.1.7.RELEASE" and this have dependency jooq 3.11.11
and I set jooqversion to 3.11.11 and now work
 
Il giorno mercoledì 28 agosto 2019 12:00:06 UTC+2, Lukas Eder ha scritto:
Lukas Eder <[hidden email]>: Aug 28 12:14PM +0200

Thanks for sharing this, Nicola,
 
Do note we've recently published a blog post about how to override Spring
Boot's default jOOQ version with Maven:
https://blog.jooq.org/2019/06/26/how-to-use-jooqs-commercial-distributions-with-spring-boot/
 
 
I hope this helps,
Lukas
 
On Wed, Aug 28, 2019 at 12:07 PM Nicola Micheli <[hidden email]>
wrote:
 
You received this digest because you're subscribed to updates for this group. You can change your settings on the group membership page.
To unsubscribe from this group and stop receiving emails from it send an email to [hidden email].